Issues regarding latest SLMapviewer Demo App

Dec 23, 2011 at 10:41 AM

Dear Pano/Elias,

Currently we are working with SLMapviewer Demo app (http://slmapviewer.codeplex.com/releases/view/78841) in VS 2010 platform on 32 bit system.

As directed by Pano and flow mentioned in the Read-me file, we have done all the necessary modifications and configured the required DLLs and MapServer binaries. We are using our own map file which I have already shared in my earlier mail in which we are getting the spatial data from Oracle Spatial database/table using OGR connection.

As mentioned, in XMLUrl (under web.config file of SLMapViewer.Web project) we have mentioned like XMLUrl = http://localhost:4072 and SLMapViewerController project path is accessible from this path in web browser too as shown in my snapshot (SLMV_Latest3). But in when I am trying to open xml.aspx in browser from the path, it is throwing some runtime error as mention in snapshot (SLMV_Latest4).

By define this above mentioned path, we are getting the error like: the remote server returned an error: not found” which I have mentioned earlier.

If, we create a new xml.aspx page using the existing one inside SLMapViewer.Web project, then it is working somewhat as mentioned in the snapshots (SLMV_Latest1 and SLMV_Latest2) in which some toolbar components are not visible due to page load event.

If possible, could you please us some solution on this which we are missing may be else we can use the components of SLMapViewerController project under SLMapViewer.Web project as it was in earlier version.

Request you once again to do the needful in a bit urgent basis as we have to proceed further and if you are available for an online session with us we can co-ordinate the same officially.

 

Regards,

Alekhya Datta

alekhya.datta@nestgroup.net | alekhya.sec@gmail.com

Dec 23, 2011 at 1:09 PM

Dear Pano,

Thanks a lot for your kind reply!!

It is to inform you that we are using VS 2010 to build the existing solution (i.e., SLMapViewer\SLMapviewer\SLMapViewer.sln).

As directed by you, we have create a virtual directory in IIS for the controller project like: "http://localhost/slmvc" as shown in attached snaps (slmvc_1.JPG and slmvc_2.JPG) and getting some xml related error when we are trying to open that xml.aspx page in web browser may be like you have mentioned.

When we are debugging our application, we are getting the baseURL correct as mentioned in web.config file under SLMapViewer.Web project, please refer attached snaps (webconfig_3.JPG and baseURL_4.JPG). But this time the earlier error has gone which was “the remote server returned an error: not found” and now the new error occurred likeAccess to the path "C:\ms4w\tmp\ms_tmp\ms_log.txt" is denied (although it has came earlier too and we have resolve this somehow).

Please look into those attached snaps and again we are looking for your further help on this, if possible….

Thanks anyway.

 

Regards,

Alekhya Datta

alekhya.datta@nestgroup.net | alekhya.sec@gmail.com

Coordinator
Dec 23, 2011 at 1:32 PM
Hi Alekhya,
The error talks about ms_log1.txt and not ms_log.txt. So I can only assume its the setting you put on the web.config of the Mapcontroller project. So first make sure you have write access to this folder and try to set both settings for the error log to the same file

Regards,
Pano


On Fri, Dec 23, 2011 at 4:09 PM, alekhyadatta <notifications@codeplex.com> wrote:

From: alekhyadatta

Dear Pano,

Thanks a lot for your kind reply!!

It is to inform you that we are using VS 2010 to build the existing solution (i.e., SLMapViewer\SLMapviewer\SLMapViewer.sln).

As directed by you, we have create a virtual directory in IIS for the controller project like: "http://localhost/slmvc" as shown in attached snaps (slmvc_1.JPG and slmvc_2.JPG) and getting some xml related error when we are trying to open that xml.aspx page in web browser may be like you have mentioned.

When we are debugging our application, we are getting the baseURL correct as mentioned in web.config file under SLMapViewer.Web project, please refer attached snaps (webconfig_3.JPG and baseURL_4.JPG). But this time the earlier error has gone which was “the remote server returned an error: not found” and now the new error occurred like: Access to the path "C:\ms4w\tmp\ms_tmp\ms_log.txt" is denied (although it has came earlier too and we have resolve this somehow).

Please look into those attached snaps and again we are looking for your further help on this, if possible….

Thanks anyway.

Read the full discussion online.

To add a post to this discussion, reply to this email (slmapviewer@discussions.codeplex.com)

To start a new discussion for this project, email slmapviewer@discussions.codeplex.com

You are receiving this email because you subscribed to this discussion on CodePlex. You can unsubscribe or change your settings on codePlex.com.

Please note: Images and attachments will be removed from emails. Any posts to this discussion will also be available online at codeplex.com




--
Pano Voudouris
Gaiocorp
Τ: +30 (2310) 500181
F: +30 (2310) 551844
Ε:
pvoudouris@gaiocorp.com
P: Kountouriotou 3 | Thessaloniki 546 25
Please consider the environment. Do you really need to print this email?
This email and any files transmitted with it are confidential and intended solely for the use of the individual or entity to whom they are addressed. Please notify the sender immediately by e-mail if you have received this e-mail by mistake and delete this e-mail from your system. If you are not the intended recipient you are notified that disclosing, copying, distributing or taking any action in reliance on the contents of this information is strictly prohibited.

Dec 26, 2011 at 3:52 AM

Dear Pano,

Thnx....

We will check the same and come back to you ASAP but our procedure as described by you is correct, right..??

 

Regards,

Alekhya Datta

alekhya.datta@nestgroup.net | alekhya.sec@gmail.com

Coordinator
Dec 26, 2011 at 2:45 PM
Yes- that's correct.

On Mon, Dec 26, 2011 at 6:52 AM, alekhyadatta <notifications@codeplex.com> wrote:

From: alekhyadatta

Dear Pano,

Thnx....

We will check the same and come back to you ASAP but our procedure as described by you is correct, right..??

Read the full discussion online.

To add a post to this discussion, reply to this email (slmapviewer@discussions.codeplex.com)

To start a new discussion for this project, email slmapviewer@discussions.codeplex.com

You are receiving this email because you subscribed to this discussion on CodePlex. You can unsubscribe or change your settings on codePlex.com.

Please note: Images and attachments will be removed from emails. Any posts to this discussion will also be available online at codeplex.com




--
Pano Voudouris
Gaiocorp
Τ: +30 (2310) 500181
F: +30 (2310) 551844
Ε:
pvoudouris@gaiocorp.com
P: Kountouriotou 3 | Thessaloniki 546 25
Please consider the environment. Do you really need to print this email?
This email and any files transmitted with it are confidential and intended solely for the use of the individual or entity to whom they are addressed. Please notify the sender immediately by e-mail if you have received this e-mail by mistake and delete this e-mail from your system. If you are not the intended recipient you are notified that disclosing, copying, distributing or taking any action in reliance on the contents of this information is strictly prohibited.

Dec 28, 2011 at 10:37 AM

Dear Pano,

Hope you are doing well!!

As discussed, we have tried with latest SLMapviewer Demo App (http://slmapviewer.codeplex.com/releases/view/78841) and also sorted out the problem that we were facing regarding SLMapviewer Controller project and now it is working as http://localhost:4072. Also we have tried with the map file provided with the download and our map file too and we are getting the output as mentioned in attached snaps (1. provided_mapfile.JPG and 3. our_mapfile.JPG). But we are missing few map tools this time like Identify, Select Features, Hyperlink as mentioned in attached snaps (2. map_tool_missing_1.JPG and 4. map_tool_missing_2.JPG) although for the provided map file the Push-pin functionality is working fine.

Request you to please look into this, if possible.

Also, with the same configuration when we are trying this in a separate system having VS 2010, we are getting some Security Error, is it related to CrossDomain.xml under controller project. As mentioned in Read-me file, we have copied all the MapServer binaries into the bin folder of the SLMapviewer controller project but in controller project we have to replace some DLLs like gdal17 with newer gdal18, is it correct or we have to use all the latest binaries. If you have the MapServer binaries used for this project, please share the same with us.

Also, request you to provide us some document on this latest application and coding aspects like code walk-through, if available and relationship between all these project under the solution like relationship between SLMapviewer and SLMapviewer Controller project as we are newer to this kind of application particularly with asp.net and open source.

Your valuable response and suggestions would be highly appreciated....

 

Regards,

Alekhya Datta

alekhya.datta@nestgroup.net | alekhya.sec@gmail.com


Jan 5, 2012 at 10:48 AM

Dear Pano,

Thanks a lot for your reply!!

We have delayed a bit to get back to you.

Regarding the map tools: Select Features, Identify and Select By Attribute are coming as mentioned by you. We have used your map file as well as our map file using shapefile, oracle spatial and postgis/postgres connections. Both map files have been attached with this e-mail (slmapview_demo.map and OrSpatial.map).

Identify: The identify features tool along with zoom to select feature is working properly with your map file but in case of our map file only identify features are showing in grid but not the zoom to select feature. (Error mentioned in attached snap: 2. Memory Error_Identify_ZoomToSelect.JPG)

Select Features: The select features tool along with zoom to select feature is working properly with your map file but in case of our map file it is not working as mentioned in attached snap: 1. Memory Error_Select_Features.JPG. Should we need to modify something in map file or in solution.

Select By Attribute: This tool is not working in either cases (Error mentioned in attached snap: 3. Memory Error_Attribute_Query.JPG).

Other map tools:

Hyperlink: We don’t have any option in our map file, but it would be great if explain us more about the same and the advantages of having hyperlink so that we can use the same.

Pushpin: It is also working fine with your map file but we have include one layer section for pushpin in our map file using which we can draw the pin on the map but while deleting the same we are getting the error as mention in attached snap: 4. Pushpin_Error.JPG

Also please guide us any changes are required in MapServer.cs file if while using PostGIS connection as mentioned in attached snap: 5. Data_Connection.JPG.

Request you to do the needful for us.

 

Regards,

Alekhya Datta

alekhya.datta@nestgroup.net | alekhya.sec@gmail.com

Jan 12, 2012 at 8:34 AM

Dear Pano,

Hope you are doing well!!

We need to have your help related to UMN MapServer.

The requirement is:

We have some feature class (GIS data in ESRI Shape-file format or in Oracle Spatial) and the corresponding map configuration file (map file) with those layer definitions. But we need to overlay those feature class on a background layer such as Google Maps or MS Bing Maps using tile/wms services. Our map file has been attached with this e-mail.

Pertaining our same map file and the SLMV application, whether we can able to get any background layer from the above mentioned services by doing some modifications in our map file as well as in SLMV application, please suggest us the method for the same, if possible.

Also we are planning to go ahead with SLMV project to cater our requirements with other functionalities and we are now in prototype/R&D stage. Therefore we need to have your extended support and any agreement related to this project we need to follow-up with before the final implementation of our project. If possible, can we have some telecon regarding the technical issues related to SLMV project.

To prepare our project SRS, we need to have a look in your other application i.e., Asset and Defect Management (http://www.mapoholic.com/mams3/Login.aspx) which is not working in your site. Hence, request you to send us some snaps or source for the same so that we can have some idea how to include SLMV into project like you did in this case, I guess. It will really help us to design our system to cater the requirements.

 

Regards,

Alekhya Datta

alekhya.datta@nestgroup.net | alekhya.sec@gmail.com